Powered by Zoomin Software. For more details please contactZoomin
Platform
Product Type
Version
Content Type
Source

Summary


This article explains why the ZVM service is crashing after the SQL 'SA' user's password had been changed on SQL database.


Symptoms

The ZVM service is crashing and the following error will appear on the SQL database log:
System.Data.SqlClient.SqlException: Cannot open database "xxx" requested by the login. The login failed. Login failed for user 'xxx'


Root Cause

This issue happens hen the user change a username or passwords in SQL External Database.


Solution

In order to resolve this issue reconfigure the SQL settings with the new password for the 'sa' user:

  1. Click Start > Programs > Zerto Virtual Replication > Zerto Diagnostics.
  2. Select the Change SQL Server Credentials option and click Next.
  3. Change the IP and username and password if necessary.
  • Server Name: The domain name and server instance to connect to, with the format <server_name>\<instance_name> or <Server_IP>\<instance_name>.
  • Specify either of the following authentication options:
    • Windows Authentication: Use Windows authentication. This option is only enabled if a specific service user account was specified in the previous Service User dialog, in which case the service account name and password are used.
    • SQL Server Authentication: Use SQL Server authentication.
  • User Name: The user name for SQL Server database.
  • Password: A valid password for the given user name.
Click Next to the end of the wizard and then click Finish.



TitleResults for “How to create a CRG?”Also Available inAlert
Feedback Feedback